You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/jboss-logmanager/jboss-logmanager-1.5.1.ebuild

33 lines
665 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="JBoss logging framework"
HOMEPAGE="https://www.jboss.org/"
SRC_URI="https://github.com/${PN/logmanager/logging}/${PN}/archive/${PV}.Final.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
CDEPEND="dev-java/jboss-modules:0"
RDEPEND=">=virtual/jre-1.5
${CDEPEND}"
DEPEND=">=virtual/jdk-1.5
${CDEPEND}"
S="${WORKDIR}/${P}.Final/"
JAVA_SRC_DIR="src/main/java"
JAVA_GENTOO_CLASSPATH="jboss-modules"
java_prepare() {
rm pom.xml || die
}