You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/jsr181/jsr181-1.0-r2.ebuild

25 lines
530 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
JAVA_PKG_IUSE="source doc"
inherit java-pkg-2 java-pkg-simple
MY_PN="${PN}-api"
MY_PV="${PV}-MR1"
MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="JSR 181 API classes"
HOMEPAGE="http://jcp.org/en/jsr/summary?id=181"
SRC_URI="http://central.maven.org/maven2/javax/jws/${MY_PN}/${MY_PV}/${MY_P}-sources.jar"
LICENSE="CDDL"
SLOT="0"
KEYWORDS="amd64 ppc64 x86"
IUSE=""
RDEPEND=">=virtual/jre-1.6"
DEPEND=">=virtual/jdk-1.6"