You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/sablecc/sablecc-3.7-r1.ebuild

39 lines
685 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Java based compiler / parser generator"
HOMEPAGE="http://www.sablecc.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
>=virtual/jre-1.6"
DEPEND="
>=virtual/jdk-1.6
source? ( app-arch/zip )"
S="${WORKDIR}/${P}"
JAVA_SRC_DIR="src"
java_prepare() {
java-pkg_clean
}
src_install() {
java-pkg-simple_src_install
java-pkg_dolauncher "${PN}" --main org.sablecc.sablecc.SableCC
dodoc AUTHORS THANKS
dohtml README.html
}