You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/sbt-bin/sbt-bin-1.3.10.ebuild

50 lines
813 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit java-pkg-2
DESCRIPTION="sbt, a build tool for Scala"
HOMEPAGE="https://scala-sbt.org"
SRC_URI="https://github.com/sbt/sbt/releases/download/v${PV}/${PN/-bin}-${PV}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
>=virtual/jre-1.7
!dev-java/sbt"
src_unpack() {
default
mv "${WORKDIR}/sbt" "${S}" || die
}
src_prepare() {
default
java-pkg_init_paths_
}
src_compile() {
:;
}
src_install() {
local dest="${JAVA_PKG_SHAREPATH}"
rm -v bin/sbt.bat || die
sed -i -e 's#bin/sbt-launch.jar#lib/sbt-launch.jar#g;' \
bin/sbt || die
insinto "${dest}/lib"
doins bin/*
insinto "${dest}"
doins -r conf
fperms 0755 "${dest}/lib/sbt"
dosym "${dest}/lib/sbt" /usr/bin/sbt
}