You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/squareness-jlf/squareness-jlf-2.3.0-r1.ebuild

42 lines
746 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
DESCRIPTION="Squareness Java Look and Feel"
HOMEPAGE="http://squareness.beeger.net/"
SRC_URI="mirror://sourceforge/squareness/${PN/-/_}_src-${PV}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="${JAVA_PKG_IUSE}"
S="${WORKDIR}"
RDEPEND=">=virtual/jre-1.4
dev-java/laf-plugin:0"
DEPEND="
app-arch/unzip
>=virtual/jdk-1.4
dev-java/laf-plugin:0"
EANT_GENTOO_CLASSPATH="laf-plugin"
java_prepare() {
cp "${FILESDIR}"/build.xml build.xml || die
}
src_install() {
java-pkg_dojar ${PN}.jar
use doc && java-pkg_dojavadoc docs
use source && java-pkg_dosrc net
}