You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/swingx-beaninfo/swingx-beaninfo-1.6.4.ebuild

32 lines
619 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="SwingX Beaninfo"
HOMEPAGE="https://java.net/projects/swingx/"
SRC_URI="https://java.net/downloads/swingx/releases/${P}-sources.jar"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
CDEPEND="dev-java/swingx:1.6"
RDEPEND=">=virtual/jre-1.6
${CDEPEND}"
DEPEND=">=virtual/jdk-1.6
${CDEPEND}
app-arch/unzip"
JAVA_GENTOO_CLASSPATH="swingx-1.6"
src_compile() {
java-pkg-simple_src_compile
java-pkg_addres ${PN}.jar .
}