You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/xml-commons-resolver/xml-commons-resolver-1.2-r1...

37 lines
795 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="An XML Entity and URI Resolver"
HOMEPAGE="http://xml.apache.org/commons/"
SRC_URI="mirror://apache/xml/commons/${P}.tar.gz"
KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
LICENSE="Apache-2.0"
SLOT="0"
DEPEND=">=virtual/jdk-1.6"
RDEPEND=">=virtual/jre-1.6"
DOCS=( KEYS LICENSE.resolver.txt NOTICE-resolver.txt )
S="${WORKDIR}/${P}"
JAVA_SRC_DIR="src"
src_prepare() {
default
java-pkg_clean
rm -rv src/org/apache/xml/resolver/tests || die
}
src_install() {
java-pkg-simple_src_install
einstalldocs
}