You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/inform/inform-6.33.1_p2.ebuild

26 lines
716 B

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MY_P=${P/_p/-b}
DESCRIPTION="design system for interactive fiction"
HOMEPAGE="http://www.inform-fiction.org/"
SRC_URI="http://mirror.ifarchive.org/if-archive/infocom/compilers/inform6/source/${MY_P}.tar.gz"
LICENSE="Artistic-2 Inform"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="emacs"
PDEPEND="emacs? ( app-emacs/inform-mode )"
S=${WORKDIR}/${MY_P}
src_install() {
default
dodoc VERSION
docinto tutorial
dodoc tutor/README tutor/*.inf
mv "${ED}"/usr/share/${PN}/manual "${ED}"/usr/share/doc/${PF}/html
rmdir "${ED}"/usr/share/inform/{include,module}
}