You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/regina-rexx/regina-rexx-3.9.1-r1.ebuild

45 lines
841 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Portable Rexx interpreter"
HOMEPAGE="https://regina-rexx.sourceforge.io/"
SRC_URI="mirror://sourceforge/${PN}/Regina-REXX-${PV}.tar.gz"
LICENSE="LGPL-2.1 MPL-1.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
S="${WORKDIR}/Regina-REXX-${PV}"
PATCHES=( "${FILESDIR}"/${PN}-3.9.1-makefile.patch )
src_prepare() {
default
mv configure.{in,ac} || die
eautoconf
}
src_compile() {
emake -j1
}
src_install() {
emake -j1 DESTDIR="${D}" install
DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
einstalldocs
newinitd "${FILESDIR}"/rxstack-r1 rxstack
}
pkg_postinst() {
elog "You may want to run"
elog
elog "\trc-update add rxstack default"
elog
elog "to enable Rexx queues (optional)."
}