You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150...

31 lines
649 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="Fork of zlib-like interface to fast block compression (LZ4 or FastLZ) libraries"
HOMEPAGE="https://github.com/bareos/fastlzlib"
SRC_URI="https://dev.gentoo.org/~mschiff/distfiles/${P}.zip"
LICENSE="BSD-1 BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
!app-arch/lz4
"
S="${WORKDIR}/fastlzlib-master"
src_configure() {
econf --disable-static
}
src_install() {
emake DESTDIR="${D}" install
find "${ED}" -name '*.la' -delete || die
find "${D}" -type d -name libfastlz -exec rm -rf {} +
}