You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/dqlite/dqlite-1.6.0.ebuild

43 lines
788 B

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
HOMEPAGE="https://github.com/canonical/dqlite"
SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3-with-linking-exception"
SLOT="0"
KEYWORDS="amd64 ~arm64"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-db/sqlite:3
dev-libs/libuv
dev-libs/raft"
DEPEND="${RDEPEND}
test? ( dev-libs/raft[test] )"
src_prepare() {
default
eautoreconf
}
src_configure() {
local myeconfargs=(
--disable-debug
--disable-sanitize
--disable-static
)
econf "${myeconfargs[@]}"
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}