You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libe/libe-0.11.0.ebuild

32 lines
619 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Hyperdex libe support library"
HOMEPAGE="http://hyperdex.org"
SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
# bit messy at the moment, next release should fix it I hope
RESTRICT="test"
RDEPEND="dev-libs/libpo6"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${PN}-0.11.0-strtoul.patch )
src_configure() {
econf --disable-static
}
src_install() {
default
# no static archives
find "${D}" -name '*.la' -delete || die
}