You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libuev/libuev-2.3.2.ebuild

24 lines
533 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A collection of useful BSD APIs"
HOMEPAGE="https://github.com/troglobit/libuev"
SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
src_configure() {
econf --enable-static=$(usex static-libs)
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
rm "${D}/usr/share/doc/${PF}/LICENSE" || die
}