You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libusbhp/libusbhp-1.0.2.ebuild

29 lines
563 B

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="Usb Hotplug Library"
HOMEPAGE="http://www.aasimon.org/libusbhp/"
SRC_URI="http://www.aasimon.org/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~x86"
IUSE="static-libs"
RDEPEND=">=virtual/libudev-147"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
econf \
$(use_enable static-libs static) \
--without-debug
}
src_install() {
default
use static-libs || find "${ED}" -name '*.la' -delete
}