You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libxdiff/libxdiff-0.23-r2.ebuild

32 lines
556 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools
DESCRIPTION="Library for creating diff files"
HOMEPAGE="http://www.xmailserver.org/xdiff-lib.html"
SRC_URI="http://www.xmailserver.org/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
src_prepare() {
default
# test utils require static libs ...
sed 's/test//g' -i Makefile.am
eautoreconf
}
src_configure() {
econf --disable-static
}
src_install() {
default
rm "${D}/usr/$(get_libdir)"/*.la
}