You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/qrosscore/qrosscore-9999.ebuild

30 lines
564 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils git-r3
EGIT_REPO_URI="https://github.com/0xd34df00d/Qross.git"
DESCRIPTION="KDE-free version of Kross (core libraries and Qt Script backend)"
HOMEPAGE="https://github.com/0xd34df00d/Qross"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="debug"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/designer:5
dev-qt/qtscript:5
"
DEPEND="${RDEPEND}"
CMAKE_USE_DIR="${S}/src/qross"
mycmakeargs=( -DUSE_QT5=ON )