You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/ocaml-ssl/ocaml-ssl-0.5.10.ebuild

28 lines
594 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DUNE_PKG_NAME="ssl"
inherit dune
DESCRIPTION="OCaml bindings for OpenSSL"
HOMEPAGE="https://github.com/savonet/ocaml-ssl"
SRC_URI="https://github.com/savonet/ocaml-ssl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
IUSE="+ocamlopt"
BDEPEND="dev-ml/dune-configurator"
DEPEND="dev-libs/openssl:0=
>=dev-lang/ocaml-3.10:=[ocamlopt?]"
RDEPEND="${DEPEND}"
src_install() {
dune_src_install
dodoc CHANGES README.md
}