You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild

32 lines
727 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit dune
DESCRIPTION="Generation of bin_prot readers and writers from types"
HOMEPAGE="https://github.com/janestreet/ppx_bin_prot"
SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
DEPEND="
>=dev-ml/base-0.14.0:=
dev-ml/findlib:=
>=dev-ml/bin_prot-0.14.0:=
>=dev-ml/ppx_here-0.14.0:=
>=dev-ml/ppxlib-0.18.0:=
>=dev-ml/ocaml-migrate-parsetree-2.0.0:=
dev-ml/cinaps:=
"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
test? (
dev-ml/ppx_jane
)"