You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/reactiveData/reactiveData-0.2.1.ebuild

35 lines
787 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit opam
DESCRIPTION="Functional reactive programming with incremental changes in data structures"
HOMEPAGE="https://github.com/ocsigen/reactiveData"
if [[ "${PV#9999}" != "${PV}" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
else
SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
LICENSE="LGPL-3-with-linking-exception"
SLOT="0/${PV}"
IUSE="+ocamlopt"
RDEPEND="dev-ml/react:="
DEPEND="${RDEPEND}
dev-ml/findlib
dev-ml/ocamlbuild
"
src_compile() {
ocaml pkg/build.ml \
native=$(usex ocamlopt true false) \
native-dynlink=$(usex ocamlopt true false) \
|| die
}