You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild

41 lines
698 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=CHORNY
DIST_VERSION=1.94
inherit perl-module
DESCRIPTION="A persistence framework for session data"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Digest-MD5
virtual/perl-File-Temp
virtual/perl-IO
virtual/perl-Storable
"
DEPEND="
dev-perl/Module-Build
"
BDEPEND="${RDEPEND}
dev-perl/Module-Build
test? (
>=dev-perl/Test-Deep-0.82.0
>=dev-perl/Test-Exception-0.150.0
>=virtual/perl-Test-Simple-0.470.0
)
"
PERL_RM_FILES=(
# Harmful at best
t/pod.t
# maintainer only
t/99postgres.t
t/99oracle.t
)