You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild

35 lines
656 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=AGRUNDMA
DIST_VERSION=1.01
inherit perl-module
DESCRIPTION="Fast C metadata and tag reader for all common audio file formats"
# License note: ambiguity: https://rt.cpan.org/Ticket/Display.html?id=132450
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
virtual/perl-ExtUtils-MakeMaker
test? (
dev-perl/Test-Warn
)
"
PERL_RM_FILES=(
"t/02pod.t"
"t/03podcoverage.t"
"t/04critic.t"
)
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}