You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/BDB/BDB-1.920.0-r1.ebuild

31 lines
485 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=MLEHMANN
DIST_VERSION=1.92
DIST_EXAMPLES=("eg/*")
inherit perl-module
DESCRIPTION="Asynchronous Berkeley DB access"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-perl/common-sense
sys-libs/db:=
"
DEPEND="
sys-libs/db:=
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}