You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/CSS-Minifier-XS/CSS-Minifier-XS-0.90.0-r2.e...

31 lines
525 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=GTERMARS
DIST_VERSION="0.09"
inherit perl-module
DESCRIPTION="XS based CSS minifier"
SLOT="0"
KEYWORDS="amd64 ~x86"
DEPEND="
dev-perl/Module-Build
"
BDEPEND="
>=dev-perl/Module-Build-0.40.0
virtual/perl-ExtUtils-CBuilder
"
src_configure() {
unset LD
[[ -n "${CCLD}" ]] && export LD="${CCLD}"
perl-module_src_configure
}
src_compile() {
./Build --config optimize="${CFLAGS}" build || die
}