You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild

30 lines
520 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=ROBM
DIST_VERSION=1.56
inherit perl-module
DESCRIPTION="Uses an mmaped file to act as a shared memory interprocess cache"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Storable
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( dev-perl/Test-Deep )
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}