You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild

38 lines
731 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=SHLOMIF
DIST_VERSION=3.000003
inherit perl-module
DESCRIPTION="A module for reading .ini-style configuration files"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="test"
RESTRICT="!test? ( test )"
# needs List::Util and Scalar::Util
RDEPEND="
virtual/perl-Carp
virtual/perl-File-Temp
dev-perl/IO-stringy
>=virtual/perl-Scalar-List-Utils-1.330.0
"
DEPEND="
dev-perl/Module-Build
"
BDEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.280.0
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-Exporter
virtual/perl-File-Spec
virtual/perl-IO
>=virtual/perl-Test-Simple-0.880.0
virtual/perl-parent
)
"