You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild

31 lines
638 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=BTROTT
MODULE_VERSION=0.08
inherit perl-module
DESCRIPTION="Read/write encrypted ASN.1 PEM files"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE=""
RDEPEND="
dev-perl/Class-ErrorHandler
dev-perl/Convert-ASN1
dev-perl/Crypt-DES_EDE3
virtual/perl-Digest-MD5
virtual/perl-MIME-Base64
"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-526.patch"
"${FILESDIR}/${P}-decryptiontest.patch"
"${FILESDIR}/${P}-testbuilder.patch"
)
SRC_TEST=do