You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild

41 lines
895 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=NANIS
DIST_VERSION=0.72
inherit perl-module
DESCRIPTION="OpenSSL support for LWP"
LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/openssl-0.9.7c:0=
virtual/perl-MIME-Base64
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
>=virtual/perl-ExtUtils-CBuilder-0.280.205
virtual/perl-Getopt-Long
>=dev-perl/Path-Class-0.260.0
>=dev-perl/Try-Tiny-0.190.0
test? (
>=virtual/perl-Test-Simple-0.190.0
)
"
# PDEPEND: circular dependencies bug #144761
PDEPEND="
dev-perl/libwww-perl
>=dev-perl/LWP-Protocol-https-6.20.0
"
PATCHES=( "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch
"${FILESDIR}/${P}-no-dot-inc.patch" )