You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110....

36 lines
680 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=JGOULAH
DIST_VERSION=0.11
inherit perl-module
DESCRIPTION="Automatically set update and create user id fields"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-perl/Class-Accessor-Grouped
dev-perl/DBIx-Class-DynamicDefault
dev-perl/DBIx-Class
"
BDEPEND="${RDEPEND}
test? ( dev-perl/DBD-SQLite )
"
PERL_RM_FILES=(
t/02pod.t
t/03podcoverage.t
)
PATCHES=(
"${FILESDIR}/${PN}-0.11-no-dot-inc.patch"
)
# Parallel tests fail sometimes due to sharing a sqlite db path
# and recreating the same table
DIST_TEST="do"