You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/DBIx-ContextualFetch/DBIx-ContextualFetch-1.30.0...

30 lines
528 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=TMTM
MODULE_VERSION=1.03
inherit perl-module
DESCRIPTION="Add contextual fetches to DBI"
SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc ppc64 sparc x86 ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-perl/DBI-1.37"
DEPEND="${RDEPEND}
test? (
virtual/perl-Test-Simple
dev-perl/DBD-SQLite
)"
SRC_TEST="do"
src_test() {
perl_rm_files t/pod.t t/pod-coverage.t
perl-module_src_test
}