You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Data-Page/Data-Page-2.20.0-r1.ebuild

30 lines
532 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=LBROCARD
MODULE_VERSION=2.02
inherit perl-module
DESCRIPTION="help when paging through sets of results"
SLOT="0"
KEYWORDS="amd64 ~x86 ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-perl/Class-Accessor-Chained"
DEPEND="dev-perl/Module-Build
test? (
${RDEPEND}
dev-perl/Test-Exception
)"
SRC_TEST=do
src_test() {
perl_rm_files t/pod.t t/pod-coverage.t
perl-module_src_test
}