You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Dist-Zilla-Plugin-CopyFiles.../Dist-Zilla-Plugin-CopyFiles...

36 lines
708 B

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=ETHER
DIST_VERSION=0.007
inherit perl-module
DESCRIPTION="Copy files from a release (for SCM inclusion, etc.)"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-perl/Dist-Zilla
dev-perl/Moose
>=dev-perl/Path-Tiny-0.70.0
dev-perl/namespace-autoclean
"
DEPEND="
dev-perl/Module-Build-Tiny
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
>=dev-perl/Module-Build-Tiny-0.34.0
test? (
virtual/perl-File-Spec
virtual/perl-Module-Metadata
dev-perl/Test-Deep
dev-perl/Test-Fatal
>=virtual/perl-Test-Simple-0.880.0
virtual/perl-if
)
"