You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Feed-Find/Feed-Find-0.70.0-r2.ebuild

55 lines
1.2 KiB

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=BTROTT
DIST_VERSION=0.07
inherit perl-module
DESCRIPTION="Syndication feed auto-discovery"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE=""
RDEPEND="
dev-perl/Class-ErrorHandler
dev-perl/HTML-Parser
dev-perl/libwww-perl
dev-perl/URI
"
DEPEND="${RDEPEND}"
src_prepare() {
sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
die "Can't patch Makefile.PL for 5.26 dot-in-inc"
perl-module_src_prepare
}
src_test() {
local MODULES=(
"Feed::Find ${DIST_VERSION}"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
if has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
perl-module_src_test
else
ewarn "Comprehensive testing requires network access. For details, see:"
ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Feed-Find"
fi
}