You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/File-RsyncP/File-RsyncP-0.740.0-r1.ebuild

35 lines
715 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=CBARRATT
DIST_VERSION=0.74
inherit perl-module toolchain-funcs
DESCRIPTION="An rsync perl module"
HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
# Bundled files make for some weirdness
LICENSE="GPL-3+ GPL-2+ RSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="
>=virtual/perl-Getopt-Long-2.240.0
net-misc/rsync
"
BDEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/${PN}-0.700.0-make.patch" )
src_prepare() {
perl-module_src_prepare
tc-export CC
}
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}