You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Gearman-Server/Gearman-Server-1.130.1-r1.e...

36 lines
730 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=PALIK
DIST_VERSION=v1.130.1
inherit perl-module
DESCRIPTION="Gearman distributed job system - worker/client connector"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-perl/Danga-Socket-1.520.0
>=dev-perl/Gearman-1.07
!!sys-cluster/gearmand
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
dev-perl/Test-Script
)
"
PATCHES=( "${FILESDIR}/${P}-Use-saner-name-in-process-listing.patch" )
src_install() {
perl-module_src_install
newinitd "${FILESDIR}"/gearmand-init.d-1.09 gearmand
newconfd "${FILESDIR}"/gearmand-conf.d-1.09 gearmand
}