You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Gentoo-PerlMod-Version/Gentoo-PerlMod-Version-0.8....

32 lines
698 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=KENTNL
DIST_VERSION="v${PV}"
inherit perl-module
DESCRIPTION="Convert arbitrary Perl Modules' versions into normalised Gentoo versions"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Carp
virtual/perl-Data-Dumper
dev-perl/Sub-Exporter-Progressive
>=virtual/perl-version-0.770.0
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
dev-perl/Test-Fatal
virtual/perl-File-Spec
virtual/perl-Scalar-List-Utils
>=virtual/perl-Test-Simple-0.960.0
)
"