You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Image-Imlib2/Image-Imlib2-2.30.0-r1.ebuild

30 lines
537 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=LBROCARD
MODULE_VERSION=2.03
inherit perl-module eutils
DESCRIPTION="Interface to the Imlib2 image library"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=media-libs/imlib2-1"
DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.28
test? (
>=media-libs/imlib2-1[jpeg,png]
)"
SRC_TEST=do
src_test() {
perl_rm_files t/pod.t t/pod_coverage.t
perl-module_src_test
}