You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Lchown/Lchown-1.10.0-r3.ebuild

31 lines
578 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=NCLEATON
DIST_VERSION=1.01
inherit perl-module
DESCRIPTION="Use the lchown(2) system call from Perl"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
DEPEND="dev-perl/Module-Build"
BDEPEND="${RDEPEND}
dev-perl/Module-Build
"
PERL_RM_FILES=(
t/pod-coverage.t
t/pod.t
)
src_configure() {
unset LD
[[ -n "${CCLD}" ]] && export LD="${CCLD}"
perl-module_src_configure
}
src_compile() {
./Build --config optimize="${CFLAGS}" build || die
}