You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Locale-Maketext-Lexicon/Locale-Maketext-Lexicon-1.0...

34 lines
766 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=DRTECH
MODULE_VERSION=1.00
inherit perl-module
DESCRIPTION="Use other catalog formats in Maketext"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-Locale-Maketext-1.170.0
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.300.0
test? (
virtual/perl-Test-Simple
)
"
SRC_TEST="do parallel"
src_test() {
perl_rm_files t/91-pod_test.t t/release-pod-syntax.t t/release-eol.t
perl-module_src_test
}