You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild

51 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=NEILB
DIST_VERSION=0.80
inherit perl-module
DESCRIPTION="Simple platform independent mailer"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE=""
RDEPEND="
virtual/perl-Digest-MD5
virtual/perl-Exporter
virtual/perl-MIME-Base64
virtual/perl-Socket
virtual/perl-Time-Local
virtual/perl-parent
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"
src_test() {
local MODULES=(
"Mail::Sendmail ${DIST_VERSION}"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
if has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
perl-module_src_test
else
ewarn "Network tests disabled without DIST_TEST_OVERRIDE=~network"
fi
}