You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild

42 lines
708 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=MHASCH
DIST_VERSION=0.011
inherit perl-module
DESCRIPTION="modular integer arithmetic"
SLOT="0"
KEYWORDS="~amd64"
IUSE="minimal test"
RESTRICT="!test? ( test )"
PERL_RM_FILES=(
"t/90_pod.t"
"t/91_pod_cover_cp.t"
"t/92_consistency.t"
"t/93_examples.t"
"t/95_versions.t"
"t/99_signature.t"
)
RDEPEND="
virtual/perl-Carp
>=virtual/perl-Math-BigInt-1.991.0
!minimal? (
dev-perl/Math-BigInt-GMP
virtual/perl-Math-BigRat
)
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-Scalar-List-Utils
virtual/perl-Test
virtual/perl-Test-Simple
)
"