You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Math-Prime-XS/Math-Prime-XS-0.270.0.ebuild

32 lines
669 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=KRYDE
DIST_VERSION=0.27
inherit perl-module
DESCRIPTION="Detect and calculate prime numbers with deterministic tests"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-perl/boolean
dev-perl/Params-Validate
virtual/perl-Carp
virtual/perl-Exporter
virtual/perl-Scalar-List-Utils
virtual/perl-XSLoader"
DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.420.0
test? ( virtual/perl-Test-Simple )
virtual/perl-ExtUtils-CBuilder"
src_test() {
perl_rm_files "t/pod.t" "t/pod-coverage.t"
perl-module_src_test
}