You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.e...

36 lines
726 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=FREW
DIST_VERSION=0.080001
inherit perl-module
DESCRIPTION="Cryptographically-secure, cross-platform replacement for rand()"
LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-perl/Moo-2.0.0
>=dev-perl/Crypt-Random-Source-0.70
>=dev-perl/Math-Random-ISAAC-1.1.0
dev-perl/Math-Random-ISAAC-XS"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
dev-perl/List-MoreUtils
virtual/perl-Test-Simple
dev-perl/Test-SharedFork
dev-perl/Test-Warn
)
"
src_test() {
perl_rm_files t/author-*.t t/release-*.t
perl-module_src_test
}