You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Module-Implementation/Module-Implementation-0.90....

37 lines
841 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=DROLSKY
DIST_VERSION=0.09
inherit perl-module
DESCRIPTION="Loads one of several alternate underlying implementations for a module"
LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Carp
>=dev-perl/Module-Runtime-0.12.0
dev-perl/Try-Tiny
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-File-Spec
virtual/perl-IO
dev-perl/Test-Requires
>=dev-perl/Test-Fatal-0.6.0
>=virtual/perl-Test-Simple-0.880.0
)
"
src_test() {
perl_rm_files "t/release-"* "t/author-"*
perl-module_src_test
}