You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Module-Refresh/Module-Refresh-0.170.0-r1.e...

27 lines
598 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=ALEXMV
MODULE_VERSION=0.17
inherit perl-module
DESCRIPTION="Refresh %INC files when updated on disk"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="test? ( dev-perl/Path-Class )"
SRC_TEST="do"
src_prepare() {
sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
die "Can't patch Makefile.PL for 5.26 dot-in-inc"
perl-module_src_prepare
}