You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Module-Signature/Module-Signature-0.810.0.eb...

35 lines
688 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=AUDREYT
DIST_VERSION=0.81
inherit perl-module
DESCRIPTION="Module signature file manipulation"
LICENSE="CC0-1.0 || ( Artistic GPL-2+ )"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-perl/Crypt-OpenPGP
app-crypt/gnupg
virtual/perl-File-Temp
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
dev-perl/IPC-Run
)
"
src_prepare() {
sed -i -e 's/use inc::Module::Install /use lib q[.]; use inc::Module::Install /' Makefile.PL ||
die "Can't patch Makefile.PL for 5.26 dot-in-inc"
perl-module_src_prepare
}