You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild

32 lines
634 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR="CHLIGE"
DIST_VERSION="0.96"
inherit perl-module
DESCRIPTION="Module for DNS service discovery (Apple's Bonjour)"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE="test examples"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-perl/Net-DNS-0.500.0
>=virtual/perl-Socket-1.750.0"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( virtual/perl-Test-Simple )"
src_install() {
perl-module_src_install
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
docinto examples
dodoc -r demo/*
fi
}