You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3...

39 lines
965 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=BPOSTLE
DIST_VERSION=0.28
inherit desktop perl-module
DESCRIPTION="A perl module for reading, writing, and manipulating hugin script files"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gui"
RDEPEND="dev-perl/URI
dev-perl/libwww-perl
>=dev-perl/Image-Size-2.900.0
>=media-libs/exiftool-6
gui? ( gnome-extra/zenity )"
DEPEND=""
PATCHES=( "${FILESDIR}/${PN}-0.28-curly-bracket.patch" )
src_install() {
perl-module_src_install
if use gui ; then
domenu "${S}"/desktop/*.desktop || die
else
rm "${D}"/usr/bin/*-gui || die
fi
}
pkg_postinst() {
einfo "Some of the scripts require 'nona', 'freepv', 'enblend', 'autotrace', and"
einfo "ImageMagick command-line tools which are available in the following"
einfo "packages: media-gfx/hugin, media-gfx/freepv, media-gfx/enblend,"
einfo "media-gfx/autotrace, and media-gfx/imagemagick."
}