You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Term-Table/Term-Table-0.8.0.ebuild

32 lines
941 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=EXODIST
DIST_VERSION=0.008
inherit perl-module optfeature
DESCRIPTION="Format a header and rows into a table"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Carp
>=dev-perl/Importer-0.24.0
virtual/perl-Scalar-List-Utils
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
>=virtual/perl-Test-Simple-1.302.72
)
"
pkg_postinst() {
# optfeature "Improved Automatic detection of terminal width" Term::Size::Any
optfeature "Improved rendering of UTF8 Characters" '>=dev-perl/Unicode-LineBreak-2013.100.0'
optfeature "Automatic detection of terminal width" 'dev-perl/TermReadKey'
}