You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Test-Base/Test-Base-0.880.0.ebuild

31 lines
715 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=INGY
MODULE_VERSION=0.88
inherit perl-module
DESCRIPTION="A Data Driven Testing Framework"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-perl/Filter
>=dev-perl/Spiffy-0.400.0
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.300.0
test? (
>=dev-perl/Algorithm-Diff-1.150.0
>=virtual/perl-ExtUtils-MakeMaker-6.520.0
>=dev-perl/Text-Diff-0.350.0
)
"
SRC_TEST="do"