You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Test-Class/Test-Class-0.500.0.ebuild

37 lines
776 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=ETHER
MODULE_VERSION=0.50
inherit perl-module
DESCRIPTION="Easily create test classes in an xUnit/JUnit style"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=virtual/perl-Attribute-Handlers-0.770.0
virtual/perl-Carp
virtual/perl-File-Spec
>=dev-perl/MRO-Compat-0.110.0
dev-perl/Module-Runtime
>=virtual/perl-Storable-2.40.0
virtual/perl-Test-Simple
dev-perl/Try-Tiny
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-IO
virtual/perl-Test-Simple
>=dev-perl/Test-Exception-0.250.0
)
"
SRC_TEST="do parallel"